FreeTrack Forum

Welcome, you're not connected. ( Log in - Register )

FreeTrack Forum > FreeTrack : English Forum > Support : FreeTrack Software > Error in Windows 8- Invalid floating point operation

RSS >  Error in Windows 8- Invalid floating point operation, Error in Windows 8- Invalid floating point operation
zazthegreat #1 13/10/2014 - 15h32

Class : Apprenti
Posts : 4
Registered on : 13/10/2014

Off line


I've been searching this forum for a while and I don't think anyone has posted about this particular problem before.

So I am running Windows 8.1 64 bit on my desktop, and I installed Freetrack a few days ago. When I ran the program, an error message popped up that said:

Invalid Floating Point Operation

After this, Freetrack opens up and looks normal but if I run the demo video, the point model plays but the skull model on the left does not. When I choose Wii Remote #1 and start the point model, it reads the first position of the LEDs and then stops working. Or if I don't have any LEDs pointing at it, it just stops working after about 5 seconds. All of this time, the skull model does not appear.

I've tried uninstalling and re-installing with run as admin and windows xp sp3, and running the program as admin and windows xp sp3. Several times. I've scanned my computer for viruses and for broken windows files (cmd sfc /scannow). The error is not logged in eventvwr. No matter what I do I still get this error on when I start the program and the software is still unusable.

To add insult to injury, I've installed the program without issue on my laptop, which is running an identical version of Windows. Didn't need to install or run in compatibility mode, just had to run as admin. Unfortunately my laptop is a sack of crap and useless for gaming.

I'm just curios if anyone has any ideas what this problem could be. Freetrack is the only program that I've had this issue with. Anyway, thanks for reading and responding!
zazthegreat #2 13/10/2014 - 16h30

Class : Apprenti
Posts : 4
Registered on : 13/10/2014

Off line

Just did a full system restore to before I first installed FreeTrack and reinstalled with run as admin and xp sp3... now it crashes as soon as I press start, no matter which device I have selected. smh.
Stormrider #3 14/10/2014 - 14h52

Class : Légende du Forum
Posts : 466
Registered on : 02/01/2013

Off line

I really don't know.

Invalid Floating Point Operation

this has got something to do with software accessing a corrupted file.But you have already took care of it.
If you have an alternative for that wii-remote, maybe you can try facetracknoir
This is also free ir-tracking software.It can work with facerecognition or with a pointtrackker-plugin(then it works like freetrack).
Freetrack is last updated in 2008 and facetracknoir(FTNOIR)  is rather new.

For now I can only write what I should do in your case.
Check your drive  with the chkdsk command(a restorepoint you have already made, so there is no need I think to make a new one)
1. download revo-uninstaller for a thorough removal of software.
2. use revo to uninstal freetrack and the bluetooth stack
3.use a registry-cleaner like ccleaner to cleanup your registry
4. download vipre rescue (a standalone virusscanner)You can use this one without disabling or removing you standard virusscanner
5. if downloaded run vipre rescue.Keep in mind it can take some time.
6. when vipre rescue is finished and possible unwanted things are removed(maybe nothing found, because there is nothing) turn of uac(user account control) and install your bluetooth stack and freetrack again.And ofcourse install freetrack with admin and xp sp3 mode.
I have read that with win8 sometimes it is better not to install software in the programfile folders but give it his own folder on your drive.
I hope you findout what your problem is and get it working.
I wish you luck,

cheers Stormrider
Edited by Stormrider on 14/10/2014 at 15h04.
zazthegreat #4 15/10/2014 - 15h26

Class : Apprenti
Posts : 4
Registered on : 13/10/2014

Off line

Thanks for your help! I will try these steps whenever I get the time lol.
Jiube #5 22/10/2014 - 02h01

Class : Apprenti
Posts : 2
Registered on : 21/10/2014

Off line

I have the exact same error , except I'm running from windows 7, and I already had it working before.

Just a short history of when it was working.

So, I had LED's and Wiimote. I've set everything up. I had prolems with making my PC recognize Wiimote, which were solved by buying a cheaper BT adapter (apparently mine was too advanced for Bluesoleil). Then it turned out, that new Bluesoleil version has weird bugs and is not recognizable by FreeTrack (at least in my config). So I installed Bluesoleil 6.4. Then it worked.

I checked it in Euro Truck Simulator 2, Il-2 Sturmovik and War Thunder. Everything worked fine (except for delay Wiimotes are known for and oversensetive configuration, but no major problems).

Then I wasn't playing those games, didn't use FreeTrack for some time. Like a week passed. Then I returned to flying sims and encountered this error:"Invalid floating point operation". Then it launches, but doesn't work properly.

When I press "Start", dots appear, but skull doesn't. The table under skull shows dots instead of numbers. Configuration indicator shows 1-dot config before pressing "Start" and 3-dots config after pressing "Start". Other tabs show weir values as well: controls have no shortcuts, all sliders show zeroes next to them even if they are set at non-zero value, but if I move sliders, they start displaying correct values. If you launch it and keep it going for some time without moving through tabs, program hangs and stops responding (i.e., window gets grayed out as usual fror Windows 7 when it notices application is not responding). The only option by that time is to close the program (pressing standard Windows 7 red button with the cross at the top-right of the window either gives out a standard end process dialogue box, or just doesn't respond and I have to use Task Manager). Hanging of the program appeares not to care if the "Start" button was pressed, just about the fact that the main tab was opened for some time. Sometimes it doesn't, though. Not sure why.

I tried reinstalling with no success. I've tried out your solution, step by step. That didn't help it either. UAC was off all the time. FreeTrack alwas runs as administrator for me. I didn't have XP compatability on, but it worked fine without it and it was the first thing I checked anyway. The only piece of information I've managed to extract after giving some time to the problem is that this error appears regardless of wether you have Wiimote connected, or even BT driver installed. It occured even when BT adapter wasn't connected and Blusoleil wasn't installed.

Some things happened to my PC during that week. Not too major, but still... Somwhere out there lies the problem, so I'll try to list everything. It might give a clue:
1. Videodriver update. Catalyst non-beta currently installed.
2. A lot of Windows 7 updates. There was like 15 updates the other day, that I installed.
3. X-Beyond the frontier installed and uninstalled.
4. X-Tension installed and uninstalled.
   Note: no additional software (like DirectX 7 and Media something-something that comes with these games) for either of these was installed
5. X2: The Threat installed, X-Superbox version, no additional software
6. Dreamfall - The Longest Journey installed, not launched yet
7. Vanishing of Ethan Carter installed and uninstalled
8. I might have changed few options in the driver, turned off some video processing features, added Drag-n-Drop driver acceleration, but I'm not sure f it happened before or after last successful launch. And I checked "Drag-n-Drop". Changed it back to "off". Didn't fix it.
I think that's it.

Personally, my first thought is drivers or Win7 updates changed something up seriously.

Next thought is X2.

In case of drivers, I need some confirmation before I try reverting.
In case of updates... I'm afraid we might need FreeTrack v2.3 that fixes it. There are some security updates there.

I can provide you with the list of installed updates.

And the last thing. My PC config:
Intel Core2Quad Q9650
Gigabyte GA-EP45T-UD3LR
MSI AMD Radeon R7 260X 2Gb OC
Windows 7 Ultimate
Wiimote (not that it matters)

I really hope we'll figure it out... Because I don't really have an alternative to Wiimote at the moment so TrackNoIR is not an option for me...

Or is there a proper plug-in that supports Wiimote too?
Edited by Jiube on 22/10/2014 at 02h10.

 >  Fast reply


FreeTrack Forum > FreeTrack : English Forum > Support : FreeTrack Software > Error in Windows 8- Invalid floating point operation

 >  Stats

1 user(s) connected during the last 10 minutes (0 member(s) and 1 guest(s)).