FreeTrack Forum

Welcome, you're not connected. ( Log in - Register )

RSS >  Problems getting started
Demious #1 14/09/2014 - 14h55

Class : Apprenti
Posts : 5
Registered on : 14/09/2014

Off line

Hello everyone,

I'm new to this site and also to the whole head tracking subject and I'm having some problems getting started.
I notice several problems so far:
1) On the pictures I see on the forum the dots on the tracking monitor are red, but in my case they are grey. Is this something from the 2.2 version vs older versions, or is something going wrong?
2) When I point the one IR-LED I'm using for testing straight at the camera, I get a very big dot on the tracking monitor, filling almost the whole monitor area, with crosshairs flashing all over it, but as soon as I turn the position of the IR-LED slightly, it turns into a small dot (same as on the pictures I see here), but without crosshairs.
3) I understand that when using 1 IR-LED, I should see 1 green dot in the right lower corner of the program window, but mostly I see 3 to 5 red dots. Very rarely this changes to 1 green dot, but that's just a fast flash.
4) If I turn my head from looking straight forward to the centre of my monitor I see the LED picked up on the tracking monitor, but when I turn my head to the side so that I'm looking straight forward to the left or right side of my monitor, the dot on the tracking monitor disappears.

The model setting is 1 single point and the rest of the settings are default.
I use a Trust camera with the IR-filter removed and a piece of a floppy disc covering the lens area.
The skull in the left box does move sometimes, but very eratically. Íf it moves, the slightest move turns it upside down and it jumps all throughout the box.

I havent even got a clue to where to start looking at how to fix this, or what posts to read that might have something to do with my issues, so any help is most appreciated.
Demious #2 14/09/2014 - 16h18

Class : Apprenti
Posts : 5
Registered on : 14/09/2014

Off line

I did  test with a red LED and an unmodified camera and I notice that my hand projects as much light as the LED does.
I tried every setting that makes any difference in how much light to pick up, cut-off/contrast/brightness/saturation/gamma/white balance/gain/exposure, but either my hand is as visble as the LED, or neither one is visible...

Mabe this can provide a hint to someone?
Stormrider #3 16/09/2014 - 09h50

Class : Légende du Forum
Posts : 466
Registered on : 02/01/2013

Off line

the difference between a red or grey dot is the stream you select, rgb or I420.
rgb gives a red dot and can be used for non ir-leds, I420 is used for ir-leds and gives a grey dot.
If you want to use a ir-led, you choose I420 at the camera tab> stream.

What kind of model do you want to make or use?
If you only use one ir-led, you choose the single point model at the model tab.
What you want of your cam is that it only sees your ir-led and not the normal light, well how do you do it?
If you give your webcam the idea that it is in a very bright enviroment, so it lowers his exposure setting.Most of the cams have auto setting enabled you must be sure to put it on before the next part.
Take a flashligt, shine in your webcam and turn of all  the auto- settings.Now it keeps a very low exposure.
You use a floppydisk? It can be a to strong filter for your cam.What you can try is make you room completely dark and try if your cam sees your led without using that floppy.
There are a few webcam of trust who doesn't work to well with freetrack, which type do you have?
Demious #4 17/09/2014 - 12h32

Class : Apprenti
Posts : 5
Registered on : 14/09/2014

Off line

Thanks for the reply, Stormrider. :)

I've got a Trust Elight full HD 1080p and a Primo.

I did indeed use a floppy disk to cover the lens for the IR, but mine has a black data disc, while I see a brown one used on some videos, not sure if this might make any difference.

This is my first electronics project, so I thought not to make it too difficult to start with, so I used the single-LED structure and I did set '1 single point' in the model menu page.

I'll give it a go and try your flashlight trick and see how it turns out and post the results.

Thanks! :D
Demious #5 22/09/2014 - 11h44

Class : Apprenti
Posts : 5
Registered on : 14/09/2014

Off line

It took me a while, but I got the tracking of the LEDs working on the Free-track monitor window. Only thing is that when I move a little too far, one or more of the dots ont he screen disappear, but I guess that might be caused by the 60 degree LEDs I'm using at the moment. The basic principle works and I can always get better LEDs when I buld the final model.

Now I'm stuck on another thing, I dont get any response from Free-track in P3D(v2.3). It should work the same as FSX, it also works with Simconnect.
Before I tried facetracknoir through Simconnect and that wroked immediatelly when I started up the software and facetracknoir also just got assignments for FSX, so if it works with FSX simconnect, it should work with P3D simconnect.
I installed SDK and ran the Simconnect.msi files again and copied the SImconnect.cfg to the Free-track folder, but no luck.

Anyone any ideas on what I can try to get this working?
Edited by Demious on 22/09/2014 at 12h42.

 >  Fast reply


 >  Stats

1 user(s) connected during the last 10 minutes (0 member(s) and 1 guest(s)).