FreeTrack Forum

Welcome, you're not connected. ( Log in - Register )

RSS >  FSX/Simconnect problems [SOLVED]
Mattressi #1 28/08/2013 - 09h32

Class : Apprenti
Posts : 9
Registered on : 28/02/2013

Off line

Hi again everyone  :)

I had Freetrack working with FSX a while ago, but I haven't used FSX in a few months now. When I tried, I put Freetrack onto my FSX profile and everything started to go wrong.

Firstly, I had no headtracking in FSX. No movement at all. I hadn't changed anything since the last time I'd used FSX (and my Freetrack FSX profile), but it just didn't work.

Then, Freetrack started having some problems. I closed down FSX, but the 3D skull in Freetrack was gone (the whole skull window had disappeared). Also, Freetrack was responding very slowly (I'd hover over an icon and it would take several seconds to highlight it with a border). Finally, I had to end the Freetrack process because it just wouldn't close.

It took me a while to figure it out, but I now know that the problem which was causing this was the Simconnect option (in Outputs). Once I unticked that, Freetrack responded normally and the skull came back. However, from what I can tell, FSX requires the Simconnect option to be ticked. I still have no tracking in FSX.

When Simconnect is ticked, Freetrack behaves erratically - sometimes it will work for a second (with the skull icon) and then the skull icon will freeze, but Freetrack will respond fine otherwise. Sometimes Freetrack just locks up, the skull disappears and I have to end the process.

I searched around some more and found a thread which suggested reinstalling Simconnect, using the Simconnect.msi on the Acceleration DVD. I tried that (and tried using the same file from JustFlight, in case it was different), but neither did anything noticeable - the same problems still occurred. I then found a post which suggested that the problem might be antivirus software interfering. I'm pretty sure I only have ZoneAlarm running, so I stopped that running and tried again. The same problem still happens.

I've run out of ideas now. Does anyone know what I can do to make the Simconnect option work (and not stop Freetrack from working)?

As always, I appreciate everyone's help. Thanks :)
Edited by Mattressi on 28/08/2013 at 15h34.
Mattressi #2 28/08/2013 - 14h35

Class : Apprenti
Posts : 9
Registered on : 28/02/2013

Off line

I read some more and saw that some people had to uninstall ZoneAlarm. I uninstalled it, restarted my computer and tried again. It's still not working.

Also, I tried unticking the "Freetrack" and "TrackIR" boxes and only ticking the "Simconnect" one, but it still didn't work.

When I tick the Simconnect box, if I already have tracking started (that is, the skull is showing and moves with my head), the skull will move for another half a second or so and then freeze (and all of Freetrack freezes). If I don't already have tracking started (no skull or skull window showing), then Freetrack still freezes anyway.
I've tried both of these methods with FSX running and also without FSX running, with the same results.

So it seems like the issue must be the Simconnect/Freetrack interface; but I just don't know what to do to fix it.

Edit: I thought I should add that I'm running the latest Freetrack version (
Edited by Mattressi on 28/08/2013 at 14h46.
Mattressi #3 28/08/2013 - 15h34

Class : Apprenti
Posts : 9
Registered on : 28/02/2013

Off line

I finally fixed it (all by myself  :blink: )!!

I'm not sure exactly what the final problem was (I got tired of methodically trying and testing each solution, so I did a few things at once).

I turned off UAC (I'm on Windows 7). I made both the FSX and Freetrack folders writable and gave all permissions (in the "Security" tab when you are in the folder properties) to them, reinstalled Simconnect once again, using the Simconnect.msi found in the /lib folder somewhere in the Microsoft Games/FSX SDK/ folder (I think I might have used the wrong one before?). Finally, I deleted every single "fix" that I'd tried previously (various files, such as a "simconnect.cfg" file with some commands in it, placed in the Freetrack folder). I restarted my computer and voila - it works! Freetrack is no longer unresponsive with "Simconnect" ticked (I think this might have been caused by the "simconnect.cfg" fix), and, most importantly, I finally get head-tracking in FSX.

I might try installing Zonealarm again and see if it still works.

Hopefully if someone has similar issues, some of this might help them (or give them a few things to try when troubleshooting).

Edit: Ok, reinstalling Zonealarm was a bad idea. It stopped Freetrack working in FSX and, once I restarted Freetrack, caused it to display the same symptoms as before (unresponsiveness/lag when simconnect was ticked, no skull, etc). I had to uninstall Zonealarm (and restart the computer) AND then had to start Freetrack, untick Simconnect, then start FSX (leaving it on the main screen - not loading a flight), then ticking Simconnect and saving the profile. Finally, after all of that (and not before any of it), I got it working again (again).

So, Zonealarm is bad. Zonealarm will also screw up your tracking/simconnect such that you need to start it in a certain order (once ZA is uninstalled) to get it working again properly.

After all that, the only problem I had was that after a few minutes, head tracking in FSX became laggy/slow. I fixed this by ending th mission, ctrl+alt+delete to get to task manager, went to 'processes', right clicked on Freetrack.exe and set the Process Affinity to Realtime. That fixed it for good. Finally!  :stuart:
Edited by Mattressi on 28/08/2013 at 16h54.
Steph #4 29/08/2013 - 09h31

Class : Moderator
Posts : 656
Registered on : 16/11/2007

Off line


thanks for this detailed troubleshooting.
palladin82 #5 13/01/2014 - 07h35

Class : Apprenti
Posts : 15
Registered on : 07/05/2009

Off line


I had a simmilar problem regarding FT.

Sudenlly when I have started FT software it was runnign very slow (to move FT window around or to change tabs and options). This behaviour only comes up when connection with simconnect was enabled. Also a 3D Skull was unavailable while simconnect interface was marked as active. When it was turned off software was running smooth and 3D Skull was present and moving.

I was trying many things but none of it solves my issue.

I have commenced a strange procedure than -

1. Start a FT without simconnect enabled.
2. Perform FT standard calibration.
3. While camera was running I have enabled simconnect interface in FT (than the whole programm start to work very slow).
4. Minimize FT and run FSX normally.
5. Launch a free flight (and inside FSX - FT was running smooth and correct)
6. Quit the game.
7. Than I have noticed that FT started to work normally again (even when simconnect interface was on)

This problem did not occured anymore on my FT.

Hope it will be handy for someone.

 >  Fast reply


 >  Stats

1 user(s) connected during the last 10 minutes (0 member(s) and 1 guest(s)).